[해결방법] Error:Minimum supported Gradle version is 2.14.1

This topic contains 0 replies, has 1 voice, and was last updated by  technote 2017-10-17 at 7:08 PM.

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #88

    technote
    Keymaster

    Error:Minimum supported Gradle version is 2.14.1. Current version is 2.10. If using the gradle wrapper, try editing the distributionUrl in D:\GoogleDrive\100. workspace\KidsAnimation_studio\gradle\wrapper\gradle-wrapper.properties to gradle-2.14.1-all.zip

    Eclipse로 작업하던 프로젝트를 Android studio로 import 하여 build를 시도하였다.
    그런데 위와 같이 gradle error가 발생하였다.

    gradle version이 맞지 않는다는 것 같은데 에러 메세지를 보니 gradle-wrapper.properties를 수정하라고 한다.

    gradle-wrapper.properties 파일을 보니 아래와 같다.

    #Mon Dec 28 10:00:20 PST 2015
    distributionBase=GRADLE_USER_HOME
    distributionPath=wrapper/dists
    zipStoreBase=GRADLE_USER_HOME
    zipStorePath=wrapper/dists
    distributionUrl=https\://services.gradle.org/distributions/gradle-2.10-all.zip

    distributionUrl이 gradle-2.10-all.zip 을 가리키고 있는 것이 아닌가.

    에러 메세지에서 가이드한대로 이 부분을 gradle-2.14.1-all.zip로 바꾸어 보자

    [변경전]
    distributionUrl=https\://services.gradle.org/distributions/gradle-2.10-all.zip

    [변경후]
    distributionUrl=https\://services.gradle.org/distributions/gradle-2.14.1-all.zip

    변경하니 에러없이 잘 동작한다.

Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.