[해결방법] Error:Jack is required to support java 8 language features.

This topic contains 0 replies, has 1 voice, and was last updated by  technote 2018-01-19 22:30.

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #282

    technote
    Keymaster

    뭔가 gradle의 설정이 꼬였나 보다. 아래와 같은 에러가 발생한다.

    Error:Jack is required to support java 8 language features. Either enable Jack or remove sourceCompatibility JavaVersion.VERSION_1_8.

    좀 찾아 보니 google에서는 더이상 jack을 지원하지 않는다고 한다. (compiler의 일종인듯..)

    그래서 아래 항목을 삭제해 주었다.

    compileOptions {
    sourceCompatibility JavaVersion.VERSION_1_8
    targetCompatibility JavaVersion.VERSION_1_8
    }

Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.