[해결방법] Error:Minimum supported Gradle version is 4.1.

This topic contains 0 replies, has 1 voice, and was last updated by  technote 2018-01-19 15:12.

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #279

    technote
    Keymaster

    최신의 youtube player api demo 코드를 구글 사이트에서 받아와 import 하니 아래와 같은 에러가 발생한다.

    android studio도 현 시점에서 최신임에도 문제가 발생한다.

    Error:Minimum supported Gradle version is 4.1. Current version is 2.14.1. If using the gradle wrapper, try editing the distributionUrl in D:\Google_Drive\100. workspace\youtubeDemo_LAB\gradle\wrapper\gradle-wrapper.properties to gradle-4.1-all.zip Consult IDE log for more details (Help | Show Log)

    해결 방법은 다음과 같다.

    에러 문구에 기입된 곳의 파일을 text editor로 연다.
    D:\Google_Drive\100. workspace\youtubeDemo_LAB\gradle\wrapper\gradle-wrapper.properties

    열어보면 아래와 같이 되어 있는데 gradle-2.14.1-all.zip 부분을 gradle-4.1-all.zip으로 바꾸어준다.

    #Mon Dec 28 10:00:20 PST 2015 distributionBase=GRADLE_USER_HOME distributionPath=wrapper/dists zipStoreBase=GRADLE_USER_HOME zipStorePath=wrapper/dists distributionUrl=https\://services.gradle.org/distributions/gradle-2.14.1-all.zip

    수정 후 저장하고 나서

    build (Ctrl+F9)를 눌러 다시 빌드하면 해당 문제가 없어진다.

Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.