[OpenWrt/LEDE] error: you should not run configure as root

This topic contains 0 replies, has 1 voice, and was last updated by  technote 2017-12-21 11:35.

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #236

    technote
    Keymaster

    LEDE의 code 를 sync 해서 make 로 build 하다보면 아래와 같이 빌드가 안되는 경우가 있다.

    root@workspace:/usr/src/lede# make make[1] world make[2] tools/compile make[3] -C tools/flock compile make[3] -C tools/sed compile make[3] -C tools/patch compile make[3] -C tools/xz compile make[3] -C tools/tar compile make -r world: build failed. Please re-run make with -j1 V=s to see what's going on make: *** [world] Error 1

    make V=s 로 상세히 로그를 보면 다음과 같다.

    checking whether mknod can create fifo without root privileges... configure: error: in'/usr/src/lede/build_dir/host/tar-1.29': configure: error: you should not run configure as root (set FORCE_UNSAFE_CONFIGURE=1 in environment to bypass this check) See 'config.log' for more details make[3]: *** [/usr/src/lede/build_dir/host/tar-1.29/.configured] Error 1 make[3]: Leaving directory '/usr/src/lede/tools/tar' make[2]: *** [tools/tar/compile] Error 2 make[2]: Leaving directory '/usr/src/lede' make[1]: *** [/usr/src/lede/staging_dir/target-mips_24kc_musl/stamp/.tools_compile_yynyyyyynyyyyynyynnyyyyyyyyyyyyyyyyyyyynyynynyyyynny] Error 2 make[1]: Leaving directory '/usr/src/lede' make: *** [world] Error 2

    root 로 빌드하지 말라는 이야기다.
    일반 계정으로 빌드하자

    • This topic was modified 9 months ago by  technote.

Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.